TAP5-2588: upgrade hibernate to 5.1.1.Final and jboss-logging to
authorBob Harner <bobharner@gmail.com>
Sat, 27 Oct 2018 21:26:41 +0000 (17:26 -0400)
committerBob Harner <bobharner@gmail.com>
Sat, 27 Oct 2018 21:26:41 +0000 (17:26 -0400)
3.1.0.GA

This fixes "java.lang.NoSuchMethodError:
org.hibernate.internal.CoreMessageLogger.debugf" error seen by some apps
with 5.5-alpha-11

build.gradle
tapestry-hibernate/build.gradle

index a19d0d5..ea5382b 100755 (executable)
@@ -14,7 +14,7 @@ project.ext.versions = [
     easymock: "3.3.1",
     servletapi: "3.0.1",
     spock: "1.1-groovy-2.4",
-    hibernate: "5.1.0.Final",
+    hibernate: "5.1.1.Final",
     slf4j: "1.7.25",
     geb: "2.0",
     selenium: "3.12.0"
index 37b54dc..2cdc43f 100644 (file)
@@ -3,7 +3,7 @@ description = "Provides support for simple CRUD applications built on top of Tap
 dependencies {
   compile project(':tapestry-core')
   compile project(':tapestry-hibernate-core')
-  compile "org.jboss.logging:jboss-logging:3.1.0.GA"  
+  compile "org.jboss.logging:jboss-logging:3.3.0.Final"  
 
   testCompile project(':tapestry-test')